Windows 8 support

Oct 15, 2013 at 1:28 PM
Hi,
Does Hawkeye work under Windows 8?
On my pc it just hang when I am point and click any .net application.
Coordinator
Oct 22, 2013 at 12:22 PM
I'll have to wait till I'm back home and have some time to spend on this one because right now, I'm not using a Win8 box. Going by my memories, I don't think there are special issues running Hawkeye under Win8. I suspect your issue is probably related to something completely different. I'll have a test at it.
Coordinator
Oct 22, 2013 at 12:31 PM
In the meantime, you may try my V2 of Hawkeye (a complete rewrite that supports far less features for now) here:
https://github.com/odalet/Hawkeye2/releases/tag/0.2.0

In order to run Hawkeye V2, you'll most probably need to download and install the following prerequisites:
Oct 22, 2013 at 12:47 PM
Hey,
I've just tried version 2.0 on my obsolete visual basic .net application.
When I drugndrop hawkeye on my app it just crashes with exception (if Im running it in debug mode):

"An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information."
Coordinator
Oct 22, 2013 at 1:09 PM
I think this happens when:
  • either you are running the .NET application (in our case either your legacy vb.net app or hawkeye itself)
  • or you are running something (hawkeye?) you downloaded from the web and you did not tell Windows it was safe (I usually right-click the zip file in the explorer and click a button that should say something like "Unlock..." in the general tab); see here for a screenshot: http://www.lansa.com/support/notes/p0348.htm
Oct 22, 2013 at 1:19 PM
Edited Oct 22, 2013 at 1:26 PM
Unlocking archive solved the problem!
It is important to notice that you have to unlock ZIP archive, not the .exe file.
Coordinator
Oct 22, 2013 at 1:31 PM
Indeed, though technically it is equivalent: if you don't unlock the archive, the extracted files are marked as "blocked" and you can unlock them one by one.